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ArchiOffice 2015 Change Log  
  

 
VERSION 132.0:   
  
Release Date: February 11 2016 

 
GENERAL: 

1. ArchiOffice – QuickBooks sync was not working due to certification issue. This was fixed. 

  
VERSION 131.0:   
  
Release Date: December 10 2015 

 
BILLING: 

1. Billing > Projects screen:  Fixed a refresh issue when filtering on Project Leader and/or date range. 
 

PROJECT: 

1. Project > Billing > Options screen: Fixed and issue where sometimes billed time in excess of a phase cap would not 
cap at $0 as it should have. 

2. Project > Billing > Summary screen: Hourly phases which are capped will now take the cap into account when 
calculating the value in the $ Remaining column. 

 
REPORTS: 

1. Fixed an issue with the Retainer Report where it would sometimes not display the complete client name. 

2. Fixed an issue with the Retainer Report which caused the certain values on the totals line to sometimes calculate 
incorrectly. 

3. Fixed an issue with the Retainer Report which caused certain project groupings to be displayed incorrectly. 
4. Enhanced the Retainer Report to show the company name of the billing client. 

5. Fixed an issue with the Profitability Cash With Expenses Report where the Payments Totals would calculate wrong 

in certain situations. 

 
VERSION 127.5:   
  
Release Date: November 12 2015  

  
INVOICING:  

1. Fixed an issue where the invoice date on a new draft invoice would sometimes appear incorrectly, in rare situations, 
when invoicing from these screens:  

Project > Billing > Summary  

Project > Billing > Budget  

Project > Billing > Invoices  

Project > Billing > Transactions.   

2. Fixed a rare issue during invoicing that prevented certain environments from being able to invoice at all.  

  

PROJECTS:  

1. Fixed an issue where the previously invoiced date on the new invoice creation screen would sometimes show the 

wrong date.  

  

BILLING:  

1. Fixed and issue where the “Show Detailed Draft” billing option was not honored when drafting from the billing 
module instead of the project module.  
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DATA CONVERSION:  

1. Fixed an issue with the Data Conversion Utility that caused errors resulting in missing table data, in certain 
scenarios.  

  

REPORTS  

1. Fixed an issue that resulted in a visible error message when memorizing reports.  

  
VERSION 127:   
  
Release Date: October 29 2015  

  

INVOICING  

1. Fixed the standard invoice template so the labels for “% Complete” and “Amount Remaining” honor the billing 

labels set by users in Preferences.  

2. When emailing an invoice from ArchiOffice we fixed the BODY field so it would not strip out the carriage returns for 

the recipient.  

3. When using the “Summarize by Role” option, No-Charge items are now broken out separately from Charge items as 

they do with the other “Summarize by...” options.  

  

PROJECTS  

1. In Projects>Billing>Invoices fixed the Print Client Statement report that is generated so projects with long names 
use word wrapping.  

2. In Projects>Billing>Options>Invoice Extras – the “Show Detailed Draft” option will now be saved when clicking the 
SAVE button at the top of the page.  

3. Fixed the Project Search screen so Project Leaders that have an apostrophe in their name will now display properly.  

4. In Project>Logs>RFIs – fixed the RFI Detail screen for projects with very long Project Names.  

5. In Projects>Slips – fixed the screen when it is set to display Expenses. The “Qty” column was using the header 

“Hrs”.  

6. Fixed the Projects>Slips screen so users with the security (our default Project Manager Workgroup), can now see 

Totals if the workgroup is given the permission to see View Hours (Others) and View Slip Values.   

7. In Projects>Tasks – if a user filters the screen to display a select list of tasks – using the Action>List menu now 

properly display a list view only for the filtered records.  

  

REPORTS  

1. Fixed the Accounts Receivable reports so they include your firm’s header logo.  

2. Many minor change to the Slip Report so it wouldn’t show a currency symbol for Totals and Grand Totals of 
Expense quantities.  

3. Fixed the Credit Memo report so the values are properly displayed with currency delimiters.  

  

TIME AND EXPENSE  

1. In Time/Expense>Expense screen, fixed the Print link so it restricts the report to the data on screen.  

2. In Time/Expense>Search screens – fixed the “Requires Approval” checkbox, as well as the Approved – YES, NO, 

ALL checkboxes so they function as expected.  

  

PREFERENCES  

1. In Preferences>Projects>Defaults>Drawing Status, when users modify the default Drawing Status values, the 

Search screens will now display the proper values throughout the program and in Search screens.  

2. Fixed a problem where a page navigation dialog box would always appear when attempting to save a custom 
report.  

3. In Preferences>Billing>Defaults – if the Invoice Number was more than 10 digits a crash would occur when an 
invoice was finalized. This has been fixed.  
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4. In Preferences>System>Print Setup removed the Output Option of “Print inline reports as PDF” since we now 
output all reports directly to PDF.   

  

CALENDAR  

1. Searching for an event now properly displays the Status field when clicked.  

  

  

  

QuickBooks Integration Tool  

1. In AOQB Sync fixed > Syncing a retainer payment to QB results in the original invoice in QB being modified to reflect 

the retainer payment. This is fixed by implementing a new option in sync settings to allow sync’d retainer payments 

to either modify the original invoice or come through as a separate transaction.   

  

VERSION 111:   
  
Release Date: September 25 2015  

  

CALENDAR  

  

1. Fixed an issue in the Calendar when creating a recurring event with “No End Date” where events wouldn’t recur 

beyond December 2016.  

2. Fixed a minor problem when creating a To Do from a Task that has a due date, it was properly displaying in the  

calendar as “All Day” however the All Day checkbox was not properly marked.  

  
INVOICING  

  

1. There was a problem with the default invoice number being incremented during drafts. Users were constantly going 

back to reset the next invoice number in Preferences. We have fixed this problem by no longer displaying the 
default invoice number field in dialog box that opens to request the Invoice Cutoff Date. Instead, we display the 

field for “Custom Invoice Number”. This custom invoice number field should only be used if you want a custom 
invoice number to be used. Otherwise upon Finalization the invoice will look at the next default invoice number to 

be used and apply it to the invoice.   

2. Fixed the screen refresh problem when entering a payment from the Billing>Outstanding screen. Now, if an invoice 

has been fully paid, it will be instantly removed from the list of outstanding invoices.  

3. Fixed the problem where a crash might occur if an invoice number had a space in the number.  

4. Fixed the problem with Invoices (and Reports) output as PDF when the currency was set other than “$”. Now all 
invoices will output with the proper currency symbol based on the settings in Preferences.  

5. When batch printing multiple invoices from Billing>Drafts or Billing>History, they will not preview in the same order 
as shown in the screen.  

6. It is no longer possible to Un-Bill a time record that displayed on a Finalized Invoice.  

7. In Preferences>Billing>Labels>Invoice Header – if the label text for an Invoice Message contained double quotes, 
an error would appear while invoicing. This has been fixed.  

8. Fixed a problem in rare situations when invoices would not be created in certain situations where time records 
existed that were both approved and unapproved.  

9. Fixed a problem where different dialog boxes would appear when creating invoices from different areas of the 
program. Now, you should always get the same dialog box asking for date ranges.  

10. Fixed a problem in certain situations when attempting to create an invoice for a project that had time records on 
Hold and the process would stop you from invoicing entirely. Now, if some records are on hold you can still create 

an invoice but it will not include these records.  

11. Removed the “Exported” checkbox from the Search and Invoice Details screen since the export feature was 

discontinued in 2010 and is no longer applicable.  

  

PREFERENCES  
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1. When using the “Restore Defaults” feature for certain preferences, we were not also restoring the state of the 
checkboxes. This has been fixed.  

2. Fixed a problem where invoices could not be created directly from the Contacts>Invoices screen if the Preference 
was set to allow the creation of invoices for Non-Approved Slips. Invoice creation was working properly from the 

Projects>Billing>Options screen and will now do so from the Contacts module.  

  

PROJECTS  

  

1. NEW FEATURE: You’ll love this! In the Projects>Billing>Summary screen, if a Phase has no budget ($0), the 

Invoice Remaining field will now also display $0 rather than subtracting the amount billed from the $0 which always 
resulted in a negative value to be billed. We understand that you may have hourly phases that you just can’t 

budget but want to bill your time for. It didn’t make sense to show the value of the billed time as deducting from 
future billings. (Thanks to the folks at HLZA for pushing for this change).  

2. RFP and Internal projects can no longer have invoices created for them from the Projects>Billing>Invoices screen.  

3. Fixed the problem when attempting to print notes from Projects>Logs>Notes>Note Details view and rather than 

printing just the single note – it would print all notes in the database.   

4. The list of employees in the Project Slips area will now match the same order they are displayed in the 

Projects>Details screen.  

5. Fixed the problem where international dates were not properly displayed in the Projects>Slips screen.  

6. You can now modify the Received Date and Planned Dates in the Projects>Notes>Submittal area.  

7. Fixed the problem in the Projects>Notes>Submittals where Received Date could not be properly be set if the 
Planned Date was blank.   

8. Fixed the problem when searching for notes in the Projects>Logs>Notes screen. Clicking on a note in the found set 

of records would open the note detail – but for a different note. The detail view now properly displays the selected 

record.  

9. Fixed the problem on certain projects when trying to change the order of the phases. They should not move up or 
down properly.  

  

REPORTS  

  

1. Fixed the problem where certain custom reports could not be output as a PDF, RTF or CSV.  

2. Fixed the problem with Reports output as PDF when the currency was set other than “$”. Now all reports will output 
with the proper currency symbol based on the settings in Preferences.  

3. Fixed the Cash Receipts Year-To-Date report so it also includes payments from the previous year.  

4. Fixed the sort order and indentation of Phases and Sub Phases in the Profitability Cash Reports.  

5. The Slip Reports now properly calculate the Total and Grand Totals in the Rate/Exp column.  

6. We no longer include Overhead Employees in the Performance reports or screens. Hip-Hip-Hooray!  

7. Fixed the problem where the Projects-Billing Summary Report and the Billing-Billing Summary report were not 

similarly formatted.  

8. Fixed the speed of the Accounts Receivable Reports. This was a problem for firms with more than 500 unpaid 

invoices where the report would take excessively long to render.  

  
TIME/EXPENSE  

  

1. Fixed a rare problem when setting or modifying tax rates for time and expense records in the Detail screen.  

2. Fixed the security problem where employees without permission to see financial data were able do a Find in the 

Time/Expense module and using the Action>Print button a report would generate with financial data.  

3. Fixed the on-screen display of Tax values for certain time/expense records. They would invoice properly but the 

screen was rounding the tax value.  

4. Fixed the unusual problem with Tax Rates being altered to an improper decimal format when changing the Job 

Code to an Additional Service Job Code.  

5. Fixed the problem where tax values might be reset if a time/expense record was moved to and from No-Charge or 
Hold and then back again.  

6. Fixed the date format in the Time/Expense>Filter screen so it honors the date format set in Preferences.  
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CONTACTS  

  

1. Fixed the ability to delete a contact from the List screen if the contact has associated entries. You will now be 

notified if the contact has entries linked and therefore, can’t be deleted until the associated entries have been 

deleted.  

2. Fixed the Next and Previous button so it works after using the Duplicate Contact feature.  

  

DASHBOARD  

  

1. NEW FEATURE: Added the ability to filter the Accounts Receivable widget by Project Leader  

2. We know the Connected Users widget is still not flawless. We recommend you hide it from view since it is unreliable 

in certain situations. We continue to work on this problem.   

  

DOCUMENTS  

  

1. Fixed a problem where certain document templates would not honor the naming convention set and instead get the 
name of the template regardless of the preference setting.  

2. Fixed a problem when attempting to add contacts to a new document from a template. If the contact was found 

using the Search method – the Project Name and Number were lost and could not be reentered manually. We now 

maintain the Project Name and Number when you search for contacts to add to the document.   
VERSION 95:   
  
Release Date: August 14 2015  

  

CALENDAR  

  

1. Fixed an issue in the Calendar > Details and Calendar > View screens where certain repeating events would not be 

placed on the correct day of the month.  

  

INVOICING  

  

1. Fixed an issue where the billing clients middle initial was not shown in the address block on the invoice even if one 

was entered.  

  

PREFERENCES   

  

1. Fixed a minor labeling issue in the Preferences > Users > Security > Projects screen.  

  

PROJECTS  

  

1. Fixed an error in the Project > Billing > Invoice screen when clicking either the “Print Statement” or “Print  

Summary” links. Previously these reports run on every project in the system rather than just the single project you 
were in at the time. This has been corrected.   

2. Fixed an error where the “Show Invoice Balance” billing option was not honored upon creation of a new project.  

3. Fixed an issue in the Project > General > Misc screen which prevented saving any value in the Secure Notes field.  

  

REPORTS  

  

1. Fixed an error in the Billing Summary Report where Credits were not being included in Net Income.  

2. Fixed an error in the Profitability Cash reports where a server error was seen on rare occasions.  

3. Fixed an issue where the Reports module would start to lag significantly after moving between various reports.  
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4. Fixed an issue in the Profitability Accrued Report where Profit was not calculated correctly if the project did not 
have a budget entered.  

  

SEARCH   

  

1. Fixed an issue in the Invoice Search Screen where the Invoice Number field would lock up and become 

unresponsive.  

2. Fixed an issue in the Project Search Screen which prevented searching by Construction Cost.  

3. Fixed an issue in the Time/Exp Search Screen where trying to use the Phase field would cause the program to 
freeze.  

4. Fixed an issue in various search screens where the predictive dropdown was incomplete with databases having 
more than 100 employees.  

5. Fixed an issue in the Submittals Search Screen where searching on various date fields would always return no 

records even when there clear were valid records.  

  

TIME/EXPENSE  

  

1. Fixed an issue in the Filter tab where the filters were not re-applied properly when navigating here from other 

screens.  

2. Fixed an issue where un-billing a No Charge entry would result in its value being reset to $0 instead of its correct  

value.  

  
  
  
VERSION 88:   
  
Release Date: June 15 2015  

  
GENERAL  

  
1. Enhancement: Reporting engine will run in a separate process, increasing performance and reliability. It is now 

possible to set recycling options just for reporting engine. This is useful for high volume users. If needed reporting 

engine can be configured to run on a different server thus allowing your application to use dedicated CPU and 
memory resources and running reports of completely different server.   

  
REPORTS  

  
1. Fixed: an error which prevented the Billing Summary report from being able to properly sort by Project Leader.  

2. Fixed: an error with the display of the Grand Totals line on the Accounts Receivable 8 Steps Report.  

3. Fixed: an error with the calculation of the Closing WIP column on the WIP Reconciliation Report.  

4. Fixed: an error with the Time Card Profitability Report which was reporting on time from overhead employees, 
which inadvertently skewed the numbers.  

5. Fixed: an error with the calculation of the invoiced column on the Profitability Accrued reports.  

6. Fixed: an error with the default name of an emailed invoice attachment.  

7. Fixed: a limitation in the file names of custom invoice templates. 8. Fixed: certain inconsistencies in the Employee 

Performance Reports.   
SLIPS  

  
1. Fixed: an error when batch updating time entries: "Slips on this list are associated with multiple projects…"  

  
BILLING  

 1. Fixed: an error with handling of dates in the Billing > Project screen, when set to International date format.  

  
  
COMPANY (ONLINE Version)  
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1. Fixed: an error in online version when company name contains an apostrophe character.  

  

  

 VERSION 62:   
  
REPORTS  

  
1. Fixed: Custom Invoices containing file name “Invoice Type A” or “Invoice Type B”, generate Error 404 upon preview 

using pdf or rtf option.   

1. Fixed: In certain scenarios, Report preview fails that utilize Selection Formula. Prompt for login dialog is also  

displayed.    

VERSION 61:  
  
REPORTS  

1. Fixed an issue where reports would not preview in PDF/RTF/CSV format. User get 404 error.  

  


