
 

ArchiOffice 2012 Build 12.0.291.0 Release Notes 
Version:  12.0.291.0 
Release Date:  26-Feb-2013 
 
FIXED ITEMS:  
Billing:  

1. Fixed a problem when creating invoices using Stipulated Sum or Percent of 
Construction methods. The invoice totals were not calculating correctly when 
using Internet Explorer only. 

2. Fixed a problem where Project Tasks would not load properly under certain 
conditions. 

3. Fixed a problem where the Invoice Title and Invoice Message would not update. 
4. Fixed a problem where phases that bill hourly with a cap were not being 

respected. Now, if the phase has a cap, when creating invoices the cap will be 
honored. 

5. Fixed a problem where certain invoice messages would not allow an invoice to 
generate.  

Reports:  
1. Enhanced the Work in Hand report to display the Contract amount, Un-paid 

amount, un-billed amount and billing method for the project. 

Documents:  
1. Fixed a problem where document templates were not correctly displaying the 

“CurrentLongDate”. When using this field, the time will also display. 
2. Fixed a problem where newly created documents would not also launch. Now 

when documents are created from templates the associated application will 
launch and open it as well. 

3. Fixed a problem where the document date displayed was not correct. It will 
now display the documents last modified date. 

4. Fixed a problem when scrolling through multiple pages of documents. 
5. Fixed a problem in Project > Documents where the scroll position of the 

selected folder would not be remembered. 
6. Fixed a problem where folders that started with the letter “u” would cause 

problems in unrelated areas of the Project module. 

Contacts:  
1. You can now search for contacts using the “Created by” and “Modified by” 

fields. 
2. Fixed a problem for contacts whose company name had an ampersand (&) 

which would cause display problems. 

Time / Expense:  
1. Fixed a problem where Totals would not always display correct numbers. 
2. Fixed a problem in the Day viewer grid in the Detail screen. It will not display 



 

records for deleted users. 
3. Fixed a problem when using the Print button from the Timecard and Expense 

Card screens if the employee field was left blank. Report will now display the 
data that is visible on the screen. 

4. Fixed a problem where the lists of Tasks would not display in the exact same 
order as set in the Project > Tasks screen. 

5. Fixed a problem where completed tasks would still be available on the timecard. 
6. In Time / Expense > Filter screen, fixed the Project Number dropdown list so 

the order is now displayed in alphanumerical order. 
7. Fixed a problem when editing a time or expense record and it would 

occasionally also modify the project name. 
8. In the Details screen fixed the Record Totals shown in the lower right of the 

screen. 
9. In the Details screen fixed the navigation for the Day Viewer grid.  

Project:  
1. Fixed a problem where the Principal, Originator and Leader fields would be 

cleared whenever a new client was assigned to a project. 
2. Fixed a problem when creating Submittals and the date would not be saved. 
3. Fixed a problem where under certain conditions projects that are invoicing 

using the Stipulated Sum method would have incorrect totals displayed. 
4. Did a major fix when adding sub-phases. If a project has already invoiced a 

phase, it can no longer be modified by creating new sub-phases. Previously, 
users were given the option to override this with a warning that would lead to 
problems they could not foresee. Now, only unbilled phases can be modified by 
adding sub-phases. If that phase has time or expenses records, a dialog will 
appear notifying the user that the slips, tasks and budget associated with the 
phase will be moved to this sub-phase. If the project does not use the option 
“Use Tasks for Time”, the user is given the option to leave the tasks at the 
Parent phase level and not push them down to the new sub phase 

Calendar:  
1. Fixed a problem where the calendar would freeze if an event name included 

apostrophe. 
2. Fixed a problem where in certain conditions the Filter Tab would not function 

properly. 
3. Fixed a problem when trying to use the “Assign Others” button to an event.  

Preferences:  
1. Fixed a problem where the ability to reorder items using the move-up and 

move-down buttons would not work. 
2. Fixed a problem when creating new users if their Name or Login Name included 

an apostrophe.  
3. Fixed a problem when changing Date from US to International and the format 



 

would not populate to the Calendar module. 
4. In Preferences > Billing > Tax fixed a problem when using fractional tax rates for 

Job Codes. It was rounding the fractions to the nearest whole percent. The 
fractions are now respected. 

5. In Preferences > Contacts  > Defaults: fixed the button for updating existing 
contacts with the modified custom checkboxes. 
 



 

ArchiOffice 2012 Build 12.0.283.0 Release Notes 
Version:  12.0.283.0 
Release Date:  18-Jan-2013 
 
FIXED ITEMS:  
Billing:  

1. In Project > Billing > Options fixed a bug where an adjustment is made for an 
invoice; it was not being saved under certain circumstances. 

2. In Project > Billing > Options invoices fixed a problem for invoices that included 
an adjustment where the sub total was not correctly calculated. 

3. In Project > Billing > Options fixed a problem for Stipulated Sum invoices where 
adjustments were being included even though the adjustment field was set to 
“no adjustment”. 

4. In Project > Billing > Options fixed a problem for Stipulated Sum invoices where 
the Basic Services section would still appear even if there were only additional 
services and no basic services.  

Reports:  
1. Fixed a problem on reports that display interest. The actual field ID was being 

displayed not the field value. 



 

ArchiOffice 2012 Build 12.0.281.0 Release Notes 
Version:  12.0.281.0 
Release Date:  31-Dec-2012 
 
FIXED ITEMS:  
Report:  

1. Revenue Summary:  Top 10 (New Report) 
2. Cash Flow vs. Revenue (New Report) 
3. New Business by Type (New Report) 
4. Work in Hand (updated) 

Billing Issues:  
1. Projects > Billing > Options:  When invoice is generated with invoice date that is 

different than current date. It still displays current date. This was corrected. 
2. Projects > Billing > Options:  Expense Mark-up (set as %) is incorrectly applied. 

This was corrected. 
3. Project > Slips:  On changing the project of a slip whose job code has a sub we 

see that it is not displayed when we use the basic/additional filters. This was 
corrected. 

Project Issues:  
1. Projects > Details > Phases/Codes:  when deleting phases, the respective job 

codes, tasks and sub-phases are not cleared. This was corrected. 
2. Projects > Billing > Budget:  screen loading was optimized. 

Preferences Issues:  
1. Preferences > Project > Phases/Job Codes:  when deleting a phase from 

preferences, the respective job codes, tasks and sub-phases are not cleared. 
This was corrected. 

2. Preferences > Project > Tasks:  You can now create up to 4 levels of tasks and 
sub-tasks. 

3. Preferences > Billing > Defaults:  "Slips Require Approval" was not remembered 
on creating a new project. This is corrected. 

Tasks Issues:  
1. Project >  Tasks:  If a task was referenced by a time or expense record users 

were allowed to delete them. This was corrected. If a Task is used by a time or 
expense record it cannot be deleted. 

2. Project >  Tasks:  Tasks referenced by time or expense were allowing adding 
sub-tasks. This was corrected. If a task is already used by a time or expense 
record, sub-tasks can no longer be created. 

Invoicing/Reports Issues:  
1. Under some scenario’s Invoice and Report headers were not displaying 

correctly. This is corrected. 



 

ArchiOffice 2012 Build 12.0.273.0 Release Notes 
Version:  12.0.273.0 
Release Date:  10-Dec-2012 
 
FIXED ITEMS:  
Projects Issues:  

1. Project – Tasks:  Under certain scenarios when user deletes or updates an 
existing task it would result in application time out. 

2. Project:   Fixed a problem when changing basic job code to additional. It would 
result in a message "Job code is in use in slips" and ignores the change.  

3. Project:  Under certain scenarios when a new project is created it would result 
in application time out. 

Billing Issues:  
1. Formula to calculate Invoice percentage was corrected. 

Report Issues:  
1. Report description for Billing Analysis changed to be more specific.  

 



 

ArchiOffice 2012 Build 12.0.263.0 Release Notes 
Version:  12.0.263.0 
Release Date:  11-Nov-2012 
 
FIXED ITEMS:  
Sync Issues:  

1. Fixed an error in syncing events longer than 3 hours from AO calendar with 
iCal/Entourage on the Mac. 

2. Fixed a problem when using ArchiOffice to generate an email in Outlook and 
AO does not use a signature. If the AO Signature field is blank it will use the 
Outlook signature default. 

3. Fixed a problem when using ArchiOffice to generate an email in Outlook. When 
AO has an HTML signature, it will not be created with HTML formatting and not 
as plain text. 

Billing Issues:  
1. Fixed a problem where retainer payments were preventing invoices from being 

deleted even if the retainer was not associated with it. 
2. Fixed the screen display in the Billing Module where the page link buttons were 

spaced too far apart. 
3. In Project > Billing > Options: Invoice Ouput tab, the Invoice Template 

dropdown list has been made wider for enhanced visibility. 
4. In Project > Billing > Options: Invoice Output tab, fixed the Invoice Message 

field to allow users to delete or modify the message. 
5. In Project > Billing > Options fixed the problem where the Current $ field value 

changed based on a “rounding” rule after clicking Save.  
6. Fixed many problems that resulted from changing Invoice methods. 
7. Fixed many problems that resulted from having sub-phases. 
8. Fixed many problems that related to budgeting hourly services. 
9. Fixed a problem where tax rates were being updated but not properly reflected 

on the invoice. 
10. Fixed a problem for invoices that include Hourly Basic Services on a project that 

uses the Stipulated Sum Invoice method. 
11. Fixed an error that would occur for invoices that had multiple payments 

applied to the projects previous invoice. 
12. When deleting transactions the grid is now refreshed to properly display 

amounts. 

Projects Issues:  
1. In Project > Slips you can now sort by column heading. 
2. Fixed a problem where Project > Tasks could not have their Budget Start Dates 

modified or removed. 
3. In Project > General>Data fixed a problem with the Folder link button. 



 

4. In Project > Slips screen fixed a problem for expense slips with single digit dates 
would have the month/date values inverted. 

5. Fixed the problem where Submittals could not be deleted in Detail view. 
6. Fixed a problem for documents that are created in folders that are shared by 

two different projects. This is a very rare situation, but the behavior for both 
projects should be the same.  

7. Fixed a problem in certain conditions where a document could not be deleted 
or edited. 

8. In Project > Slips, if you select Type = Expenses – the screen now displays 
Expense Type not Employee 

9. In Project > Billing > Budgets now all phases display the percentage field to two 
decimal places. 

10. In Project > Tasks, fixed the problem when searching for Tasks, the Cancel 
button would not work. 

11. In Project > Logs > RFIs, fixed a problem where the description could not be 
modified or deleted. 

12. In Project > Events fixed the filters so Assigned User and Assigned Contact now 
function. 

13. In Project > Tasks fixed the search so the Extend and Reduce functions work. 
14. In Project > Tasks fixed a problem where To-Dos have been given a date but it 

does not display in the To-Do detail screen. 
15. Fixed miscellaneous problems with To-Dos created from Tasks. 
16. Fixed a problem creating events from the Project > Events module using the 

Action>New button would open the Appointment Detail view but not apply the 
Project Number and Project Name to the new record. 

17. In Project > Logs > Drawings > Detail view, fixed a problem when creating a new 
record and then attempting to delete it. It would delete the prior record not 
the current one. 

18. Fixed a problem in the Project > General screen. When adding a new Project 
Contact and clicking the Cancel button user would be taken to Dashboard 
rather than the original screen. 

19. In Project > General > Data fixed the Construction Cost field to be currency 
rather than text. 

20. Added a validate procedure when creating Awards in the Project > General > 
Data screen so that blank records can’t be created. 

21. Fixed a problem where the Project Leader and Project Principal fields were not 
being saved with the invoices created for the project. 

22. Fixed a problem in Project > Logs>RFIs where advancing to the next page would 
not function. 

Contact Issues:  
1. Fixed the alignment problem that would occur after loading image files in the 

info screen. 



 

2. Fixed a problem where changes made to a contacts address tab were not being 
saved if the user clicks to a new tab first and is prompted to save. 

3. Fixed the Cancel button when searching for Contact>Log>Notes 
4. Fixed a problem when new communication fields could not be added to a 

contact under certain conditions. 
5. Fixed a problem where notes could not be deleted from Contacts>Logs. 
6. Fixed a problem when searching for invoices from Contacts>Invoices screen 

would not return the found set but instead create a new contact record. 
7. Fixed a problem for firms with extremely large contact databases where a long 

delay would occur when attempting to display Company Name or Last Name 
fields. 

8. Fixed a problem where assigning a Document to a Note, Submittal, RFI or 
Drawing log would not actually link the document. 

9. Fixed a problem where assigning a Project to a Note, Submittal, RFI or Drawing 
log would not actually link the Project. 

10. Fixed a problem where assigning a Contact to a Note, Submittal, RFI or Drawing 
log would not actually link the Contact. 

11. Fixed a problem where employees in the Contact database would have their 
names edited using the Name Link button in Contacts. Upon changing the 
name, the employee’s time records would not migrate to QuickBooks properly. 

Calendar Issues:  
1. Fixed a problem where To-dos created from Project > Tasks were not properly 

saving.  
2. Fixed a problem where creating repeating events could not be achieved under 

certain conditions.  
3. Fixed a problem where repeating events would not end based on the number 

of occurrences requested. 
4. Fixed a problem when saving Calendar records in detail view would not display 

the visual cue that the record was being saved. 
5. Fixed a problem where international date formats were in use but the column 

headers were using US format. 
6. Fixed display problems for attendees of an event in detail view. 
7. Fixed a problem for Mac users where events that are toggled ON for the All Day 

field would not display current time when toggled OFF. 
8. Fixed a problem where To-dos created from Project > Tasks and assigned to a 

user would not display in list view when using the Calendar Action>My List 
button. 

Dashboard Issues:  
1. Fixed a problem for International users where the Dashboard would return an 

error or crash. 



 

Time / Expense Issues:  
1. In Timecard view fixed the Project field so when it is selected it will display 

based on the user preference settings. 
2. In Timecard view fixed a problem where the total hours for the week that 

included hours for Saturday and Sundays would not properly calculate. 
3. Privileged users can now modify the Cost Rate for a time or expense record 

regardless of its bill status. 
4. Fixed a problem when updating incomplete time or expense records that had 

the “X” icon denoting they are incomplete. If the Update procedure makes the 
record complete, the “X” icon will be changed to a checkmark.  

5. Fixed the List view so that Time records would display Job Codes and Expense 
Records will display the Expense Type. 

6. Fixed a problem when updating the Cost rate in List view. It would not always 
update the found records with the new Cost Rate. 

7. In Time / Expense Filter screen now you can filter by Status of Approved. 
8. Fixed a problem in Time / Expense Detail view where in certain conditions the 

Save button would not be visible. 
9. Fixed a problem in List view when clicking Find All the security settings for the 

user were not being honored. 
10.  Fixed security breaches in  Time / Expense module and Projects module so 

users can not see hours of other employees if not privileged. 
11. Fixed the Update-Reimb and Update-Non-Reimb feature in List view. 
12. Fixed miscellaneous problems related to the Update feature in List view. 
13. Fixed a problem in the Time / Expense>Detail screen when using the Day View 

Grid with Project or Employee Name filters. 
14. Fixed a problem with the Time / Expense>Detail screen when the Day View 

Grid parameters would be cleared out when using the Action>New button. 
15. Fixed a problem in the Time / Expense>Detail screen when using the Day View 

Grid without any Project or Employee Name. Now it will display all records in 
the date range.  

16. In Time / Expense>Filter view fixed a problem when sorting by Date. 
17. Fixed a problem when creating new time or expense records from Project > 

Slips screen. It will not add the original Project’s Number and Name to the 
record. 

18. Fixed a problem when only a partial project name would appear in the Project 
Name dropdown list when creating a time or expense record. 

Document Issues:  
1. Fixed a problem for Internet Explorer 9 users where changing the display rows 

in Project > Documents from the default to 100 would result in an error where 
no records would be displayed. 

2. Fixed a problem in Project > Documents when filters are in use and paging 
through the list would not function properly. 



 

3. Fixed a problem in Project > Documents for files that had an apostrophe in 
their name would be duplicated upon a Save. 

4. Fixed a problem in Project > Documents when filters are in use and user would 
attempt to delete a document (or delete the link to the document), and the 
page would not refresh. 

General Issues:  
1. Fixed an issue when sorting in list view, the sort order would change when 

moving to the next page. 
2. Fixed a problem when searching for invoices by invoice number and then using 

the Find All button afterwards. If a user then sorted by column it would revert 
to the searched records, not All. 

Preference Issues:  
1. In Preferences>Users>Performance, fixed the screen so it only displays active 

employees and not terminated or on-leave employees. 
2. No longer can Expense Types that are in use be deleted from Preferences. 
3. Fixed the problems related to privileges for users to access Project > Billing 

screens. 
4. I’m testing this log file to see who really reads it. If you are an ArchiOffice 

customer and read this, please email burns@bqe.com and you will receive a 
special shout-out on our Facebook page and Twitter feed. 

QuickBooks Sync Issues:  
1. When creating vendor bills in QuickBooks the tax rate was not being sent to 

ArchiOffice. This has been fixed. 
2. Fixed the problem sending employees with Salutations to UK version of 

QuickBooks. 
3. Changed SmartMatch tool so it would not display ArchiOffice contacts without 

a first or last name. 

Report Issues:  
1. Added the ability to sort invoices in Reports. 
2. Fixed a problem when an error would be generated in certain situations when 

creating a Timecard report. 
3. Improved reports so they properly display phases and sub=phases to show 

their true relationship. 

Search Issues:  
1. Fixed a problem when searching for Transactions by Client Name. 
2. Fixed a problem when searching for Invoices it would include draft invoices. 

Only finalized invoices are now searched. 
3. Fixed a display issue if a search for invoices resulted in no records being found. 



 

ArchiOffice 2012 Build 12.0.245.0 Release Notes 
Version:  12.0.245.0 
Release Date:  17-Oct-2012 
 
FIXED ITEMS:  
Billing Issues:  

1. In Project > Billing > Options If a project is using the Unit Cost invoice method, a 
problem was fixed which involved sub-phases not having the amount 
remaining to invoice correctly calculated 

2. In Project > Billing > Budget If a project is using Unit Cost invoice method, a 
problem resulted from toggling the Set Budget By between Fee and Percentage 

3. In Project > Billing Budget fixed a problem when checking and then un-checking 
the Hourly checkbox for a phase with sub-phases 

4. In Project > Billing > Options when using Percentage of Construction or Unit 
Cost fixed the problem where the Remaining Invoice fields were not being 
updated properly after creating an invoice 

5. In Project > Billing > Budgets fixed a problem which would result in a crash 
when creating a new project and budgets were provided with hours and the 
fee had a decimal places 

6. In Project > Billing > Budget fixed the problem when budgets were created with 
hours and fees and then moving to the Project > Billing > Options screen and 
setting the invoice method to either Percentage of Construction or Unit Cost. 
Values were not updating correctly 

7. In Project > Billing > Options when invoice method is Unit Cost proper updates 
were not being seen in the Project > Billing > Budget screen for Fees 

8. Project > Billing > Options fixed a problem when Stipulated Sum invoice 
method was used and an invoice finalized. In certain situations the Remaining 
Amount column would display a $0 

9. In Billing > Drafts fixed the problem when clicking the “All” checkbox and 
clicking the trashcan to delete all drafts. This process now works 

10. Billing > Project screen fixed the calculation for Totals of the Last Invoice 
Amount 

11. Fixed a problem where Stipulated Sum invoices were rounding totals even if 
the actual amount included decimals 

12. Fixed the problem creating Unit Cost invoices with sub phases 

Preferences:  
1. In Preferences>Users>Security:  Projects – when a user is prevented from 

seeing any of the 5 screens associated with Project >Billing this function now 
works. Previously, a user would be provided a warning that they are not 
allowed access, but they page would load anyway 



 

Projects:  
1. In Project > Events – fixed a problem when attempting to create a new event 

using the NEW button. It would move to the Calendar module but not properly 
populate the Project Name and Project Number fields.  

2. Fixed a problem when ToDo’s are created from a Project Task and would not 
appear on the Dashboard in certain situations 

3. Fixed a problem with ToDo’s created from Tasks that already had a Budget 
Start/End date set for the task. The ToDo was not inheriting the date 

4. Project > Billing > Options screen fixed the problem with sub phases not 
properly showing the Actual % when Time is associated with the sub phase 

5. Fixed a problem that would prevent users from deleting a Submittal 
6. Project >Billing > Options – fixed a problem where the Current $ field value 

would arbitrarily change after clicking the Save button 
7. Fixed a problem where searching for transactions by client was not functional 
8. Project > Documents – fixed a problem where hidden files (created by the OS 

or a temp file by an application) in the project folder were being displayed 
9. Project > Documents – enabled the Rows dropdown menu to allow users to 

determine how many documents should appear on screen before needing to 
advance to the next page 

10. Project >Documents – fixed the problem when deleting a file (link). It was not 
changing the display color of the file name to red which indicates it is not part 
of the database 

11. Project > Billing > Budgets – fixed the problem where a phase with sub phases 
was changed to Hourly – the parent phase were still displaying a percentage 
amount even though the sub phases were zeroed out 

Contacts:  
1. Contacts>Logs- fixed a problem when using the Date Filter fields in the Detail 

view 

Reports:  
1. Fixed a problem with Time and Expense reports where the Totals and Totals + 

Tax + Markup were incorrect if a time record was marked as No-Charge 
2. Fixed the Project >Budget vs. Invoiced Report where certain fields were not 

calculating properly when sub phases exist 
3. Fixed the Billing reports so they would not include Draft invoices 

Time & Expense:  
1. Time/Expense>Filter - Fixed the filter tab to included “Approved” in the status 

field 
2. Time/Expense>Detail - Fixed a problem where in very rare instances the Save 

button would disappear from view. 



 

ArchiOffice 2012 Build 12.0.239.0 Release Notes 
Version:  12.0.239.0 
Release Date:  5-Oct-2012 
 
FIXED ITEMS:  
Billing Issues:  

1. In Project > Billing > Options > Stipulated Sum Grid, fixed an issues where the 
“Invoiced Past %” totals field would contain “NaN” rather than the correct 
number 

2. In Project > Billing > Options > Stipulated Sum Grid fixed an issue where upon 
finalizing an invoice the Past % fields were updated incorrectly 

3. In Project > Billing > Options screen fixed an issue when creating draft invoices. 
The Invoice Past % field was being modified as if the invoice was already 
finalized. This would also create incorrect values on the actual invoice 

4. In Project > Billing > Options > Stipulated Sum Grid, modified the layout so it 
will always displays two decimal places 

5. In Project > Billing > Options fixed an issue for a project that has sub-phases, 
where the Invoiced Current % and Invoiced Current % Totals are not reconciling 
properly 

6. Fixed an issue on stipulated sum invoices where the Fee Summary Totals field, 
and the Remaining Totals field did not sum correctly 

7. Fixed the distortion problem for footer logos on the standard invoice templates 
8. On a Stipulated Sum invoices, fixed an issue where the "Previously Invoiced:  

Amount Billed " field was displaying the incorrect value 
9. Fixed an issue related to deleting credit payments where the total payments 

were not properly updating to reflect the deleted credit 
10. Fixed an issue were setting a tax rate for a project in the Project > Billing > 

Options > Tax > Tax methods screen and then later changing the project to “No 
Tax” was not updating all the existing current records so as not to include tax 
on an invoice 

11. Project >Billing > Budgets fixed an issue in certain browsers where expanding a 
parent phase would create a blank screen 

12. Fixed the problem where expenses marked Employee Reimbursable would not 
appear on invoices. Only non-reimbursable expenses should not appear on 
invoices 

Contact Issues:  
1. Contacts>Logs>Drawings fixed the problems associated with assigning a project 

and adding a drawing to the record 
2. Contacts>Events fixed the Help button 
3. Improved the speed when performing a QuickSearch in the Contacts module 

for large databases 
4. Fixed the problem when performing a Contact Search and clicking the Name 



 

field on large databases 
5. Contact>Invoice fixed the problem which would change the Account Balance to 

zero when sorting by any of the columns 

Data Conversion Issues:  
1. Fixed an issue with databases converted from prior versions of ArchiOffice 

where the Dashboard would sometimes not display properly 
2. Fixed an issue with databases converted from prior versions of ArchiOffice 

where the communication details for a user would be missing 

Project Issues:  
1. In Project >Tasks fixed the problem where task start and end dates could not 

be removed 
2. In Project > General>Data, fixed the link to Change Folder for Project photos 
3. Project >Details fixed a problem when deleting phases and leaving only one 

would result in the inability to highlight or activate it 
4. Project >Details>Phases / Codes fixed a problem where Job Codes had Sub 

Codes and Sub-sub Codes. When attempting to reorder the parent Job Codes a 
crash would occur 

5. Project >Tasks fixed the Cancel button when conducting a Search 
6. Project > Search – fixed the Project Number search screen so the search is 

“Equals” not “Like”. This means if you search for a project number “1000” it will 
only return a project with that number and not a project number “1000a” as 
well 

7. In Project >Budgets changed the % field to display two decimal places 
8. Fixed the problem when making over payments on projects, creating new 

invoices and then deleting the prior over payment. The Invoice Balance Due 
was not properly updating 

9. Project > Billing > Options fixed the Interest field so it would display as a 
percentage and not a dollar 

Document Issues:  
1. In Project >Documents added a feature to Save All the documents into the 

database. Now you can save a selected document or all documents easily 
2. Fixed an issue where users would get an error message about "Missing CSS 

files" when trying to open a Word document using Chrome or Internet Explorer 
browsers 

3. In Project >Documents Fixed an issue whereby in certain situations when using 
the Action>Save Selected Item would return an error that the parent folder is 
not yet saved 

4. In Project >Documents fixed an issue where a user would not be able to edit a 
document in certain folders 

5. In Project >Documents fixed the problem with documents vanishing from the 
screen when attempting to sort by description 



 

6. Fixed the problem where certain users could view reports and not project 
documents while other users could only view project documents and not 
reports 

7. Project >Documents fixed the problems related to document creation and 
deletion for projects that share the same project folder. NOTE:  This is an 
unusual situation and not recommended 

Time / Expense Issues:  
1. Fixed a problem when attempting to print a Timecard report from the Timecard 

screen for certain users 
2. Fixed a problem where time and expense records that have been finalized and 

marked as Billed could not have their cost rates modified by privileged users 
3. Fixed a problem where incomplete time and expense records are updated but 

the incomplete icon is not updating to reflect the fact that the slip is now 
complete 

4. Fixed a problem in the Time and Expense screens where the Project field would 
display all active projects instead of only the active projects for the selected 
employee 

5. Time/Expense>List screen fixed the Update Cost Rate feature which was not 
properly updating the cost rates for the found set of records 

General Issues:  
1. Fixed an issue where the Help button would not function after performing a 

search in all modules 
2. Fixed a problem encountered by certain users when attempting to create a 

new database 
3. Preferences>User>Details>Projects fixed a spelling error on screen 
4. Fixed an issue for users who installed cleanly with version 2012.0.208.0 where 

new databases would display the EngineerOffice logo on reports and invoices 
rather than the ArchiOffice logos 

5. You can no longer delete Expense types if they are in use 

QuickBooks Sync Issues:  
1. Fixed an error that would occur when syncing ArchiOffice with the Canadian 

version of QuickBooks. The error was related to Province settings in 
QuickBooks 

2. Fixed an error that would occur when syncing ArchiOffice with the Canadian 
version of QuickBooks. The error was related to Getting Payments from 
QuickBooks 

3. Fixed the problem when syncing ArchiOffice with the Canadian Version of 
QuickBooks. The Communication types for the contact did not transfer to 
QuickBooks 

4. Fixed the problem when syncing ArchiOffice with the Canadian Version of 
QuickBooks. The Country field was not being transferred from QuickBooks to  



 

5. Fixed a problem for ArchiOffice contacts that have no First or Last Name. The 
ArchiOffice QuickBooks Smart Match tool would have no way of allowing a user 
to figure out the record 

6. Fixed the problem with syncing with QuickBooks when it is in multi User Mode 
7. Fixed the way vendor bills in QuickBooks are synced into ArchiOffice. If the 

vendor bill has no items associated with it the ArchiOffice description field 
would have unnecessary dashes in front of the vendor name 

8. Fixed a problem when syncing payments from QuickBooks. If the payment fully 
pays off the invoice, ArchiOffice was not flagging the invoice as fully paid 

Calendar Issues:  
1. Calendar>Details Screen:  fixed the issue with start/end times displaying twice 

when attempting to Repeat the event 
2. Fixed the calendar “Today” button to work throughout the application for all 

browsers 
3. Fixed user interface issues in the Calendar>Details 



 

ArchiOffice 2012 Build 12.0.232.0 Release Notes 
Version:  12.0.232.0 
Release Date:  26-Sep-2012 
 
FIXED ITEMS:  
Billing Issues:  

1. Fixed issues related to invoicing with Stipulated Sum invoices where hours for 
fixed fee phases were being included in total hours for hourly fees 

2. Fixed an issue where phases and sub phases would not always display in the 
expected order 

3. Invoices that itemize time by employee now allow the full employee name to 
be displayed, not just their initials 

4. Fixed a problem where the wrong client name was being used for invoices. The 
name and address from the client’s billing tab are now being used not just the 
address and the main contact name 

5. Fixed an issue where certain databases converted from prior versions of 
ArchiOffice with sub phases were showing amounts remaining to invoice but 
the parent phase was showing $0 

6. Fixed an issue in the Billing > Projects module where the column total was not 
calculating correctly 

7. In Project > Budgets, the phases and sub phases now display the percentage 
field to two decimal places consistently 

8. In the Billing Module improved the user interface for page links displayed at the 
bottom of the screen 

Project Issues:  
1. In Project >Details fixed an issue when employees are deleted from the 

database the fields changed to “Deleted”. Now their name will remain in the 
display but will not be available in the dropdown list 

2. In Project > Budgets, the phases and sub phases now display the percentage 
field to two decimal places consistently 

3. In Project > List view fixed the tool tip displayed when hovering over the Edit 
icon. The tooltip now displays “Edit Project” 

4. In Project > Logs>Submittals fixed an issue where the Description field was 
unnecessarily truncated 

5. In Project >Billing > Options the Invoice Output tab displays a wider Template 
dropdown menu to accommodate long invoice template names  

Search Issues:  
1. Fixed the Project Search screen so entering in a project number will only find 

projects of that number, not projects that include that number 

Time/Expense Issues:  
1. In Project > Billing > Invoices you can now click on a value in the Totals column 



 

and display a list of time/expense records that are linked to that invoice 
2. Fixed an issue when updating a list of records in the Time/Expense List view. If 

the records are marked as incomplete and after updating them they are 
complete, their status now correctly updates to complete 

3. In Project > Slips fixed an issue when the radio selection is set to Expense. Now 
the “Employee” column is changed to “Expense Type” 

4. Fixed the Time/Expense List screens Update function for updating cost rates 

Contact Issues:  
1. Fixed a problem in the Contacts>Detail>Miscellaneous screen where saving 

data was not being properly saved 

Preference Issues:  
1. In Preferences>Users>Sync changed references to “MAC” to “Mac” 
2. In Preferences>Users>Performance the list of employees now only includes 

active employees  

Document Issues:  
1. In Project >Documents fixed an issue when hovering over the name of a 

document. Now the full file name will be displayed regardless of whether the 
document is added to the database or not 

2. Fixed an issue where documents were not able to be opened when referenced 
from Mac OS 

Miscellaneous Issues:  
1. Fixed miscellaneous conversion issues discovered during customer conversions 

from prior versions of ArchiOffice. 

 



 

ArchiOffice 2012 Service Pack 1 Release Notes 
Version:  12.0.229.0 
Release Date:  20-Sep-2012 

FIXED ITEMS:  
1. Updated Help file 
2. Updated Conversion Tool 
3. New Sample Company File component 
4. Preferences > System>Invoice Logos:  fixed the default logo  
5. In Preferences > System > Print Setup:  fixed a bug for converted databases 

where the standard label and envelope dropdown lists were blank 
6. Preference > User > HR:  fixed problem of adding employees 
7. Contact > Project:  fixed problem using the Delete Project button 
8. Contacts > Logs > Notes:  fixed an issue where certain users were unable to add 

notes in this screen only 
9. Project > Details:  fixed a bug where Project Status was not being properly saved 
10. Project > General>Performance:  fixed a problem where additional services were 

incorrectly displaying a project as over-budget 
11. Contacts > Documents:  fixed an issue where certain users were unable to create 

new documents 
12. Contacts > Details:  fixed an issue where the Avery 3261 label would not print 

correctly 
13. Project > Tasks:  fixed a problem where the Search Task button was not working 

properly and was returning a blank list 
14. Project > Documents:  fixed the Action menu to save selected documents or all 

documents to the database 
15. Project > Documents:  added to the Action menu an item called Set Project 

Folder (Enterprise edition) 
16. Project > Documents:  added to the Action menu an item called Open Project 

Folder (Pro and Enterprise editions) 
17. Project > Documents>List:  fixed a problem where duplicate documents would 

appear in certain situations 
18. Project > Documents:  fixed the tool tips for the Action menu 
19. Project > Documents:  fixed an issue where in rare situations a document could 

not be created and an error was telling the user a folder needed to be selected 
first even though it was selected 

20. Set Project Folder:  fixed a problem where the dialog was displaying the 
templates path rather than the project path  

21. Project > Tasks:  fixed a problem where dates for tasks were not being properly 
saved 

22. Project > Billing > Options:  fixed a screen refresh issue for calculations 
23. Project > Billing > Options:  fixed an issue where Stipulated Sum projects were 

displaying incorrect values in the “Past $” and “Remaining” columns 



 

24. Fixed a bug where in certain situations, expenses didn’t show up on invoices, but 
the totals were still correct 

25. In Time/Expense > Timecard:  fixed a problem where the Print button would not 
always generate the timecard report 

26. Billing > Projects:  fixed a problem where the screen would take too long to load 
and/or cause a SERVER error 

27. Improved the AppleScripts fixing a problem where opening documents would fail 
for Mac OS 10.8 users 

28. Fixed an issue when time and expense records were marked as DRAFT and a user 
would make the project require slip approval afterwards. If the draft was deleted, 
the time or expense record had been automatically marked as Approved but the 
checkbox was not displaying correctly 

29. Various user interface issues fixed 
30. Calendar > Detail:  fixed an issue where an assigned user (other than the creator 

of the item) to a To-Do was not seeing the item in the Dashboard>To-Do list 
31. Fixed a bug where a user who was denied access to see the Time and Expense 

records for another user was also denied access to all screens in Projects. Only 
the Project > Slips screen is denied 

32. Reports:  fixed a problem for users on a Firefox browser where the search results 
were not being properly displayed before running the report  

33.  New Reports  
34. When Non-Reimbursable option for an expense is checked:  fixed an issue where 

no details were showing up on the Invoice. Also repaired:  Details not appearing 
when both ER & NR options are checked 

35. Syncing with Outlook:  fixed an issue where it was creating the folder as       
EngineerOffice instead of ArchiOffice 

36. Error while transferring client to QuickBooks using customer database is now 
fixed 

37. Help related links fixed 
38. Tasks Search screen:  fixed issue where Search wasn’t working well and was 

displaying a blank list 
39. Project folder dialog always showing templates directory in tree view:  fixed— it 

now shows as per path given by the user in the text box  
40. Fixed:  project documents list showing duplicate documents in case of same 

location of multiple projects 
41. T/E List View:  fixed problem when users selected Change Project or Bill option of 

Update feature and clicked cancel, the totals (Hrs, Time, Exp) were shown as 
zero 

42.  In Project > Slips > Expense radio button:  fixed issue of Totals and Expense Type 
overlapping when entries in the grid were more than 7 

43. RFI > Contacts > same RFI event on Calendar screen > View RFI link >  Assign 
Document link:  fixed issue where the Assign Document screen opens, but when 



 

user tries to assign a document to RFI, they notice Assign screen does not get 
closed, though the documents get assigned 

44. Contacts > Misc Tab:  Assigned to dropdown list overlaps 
45. Fixed:  issue when a user has multiple documents open, then scrolls through the 

documents, they notice document entry overlaps with upper border 
46. Invoice phase organization:  fixed issue where sub-phases exist incorrectly  
47. Fixed:  issue of Help button not working in List of Tasks screen 
48. General tab of Projects:  fixed issue of being unable to assign a contact to the 

attendee list when editing a milestone. Also repaired:  issue of when user clicks 
Assign, the pending status of this Event disappears 

49. Project > Slips:  fixed issue of Time radio button and Expense radio button being 
reversed when appearing in the grid. Also repaired:  when user selected any 
phase in the Expense entry grid, they only got the expense of that phase. Also 
repaired:  when users wanted to get the expense of all phases, they were hitting 
the Clear filter, which, instead of displaying expense entries, was displaying time 
entries 

50. Billing > Project:  fixed that the list was overlapping with Total and Grand Totals 

NEW FEATURES:  
1. Project > Documents:  implemented the Custom Folder path to allow users to 

designate the location for project documents. This feature is accessible for 
Enterprise users from the Action Menu 

2. Project > Documents:  implemented the Open Project Folder feature to allow 
users to open the project documents main folder using their operating system. 
This feature is accessible to Enterprise users from the Action menu 

3. Project > Documents:  added a SAVE ALL feature to make database records of all 
the project documents. This feature is accessible to Pro and Enterprise users 
from the Action menu 

4. Implemented the Thumbnail feature for documents 


